如何强制eclipse使用指定的界面语言?

时间:2009-11-20 14:01:57

标签: eclipse configuration

我的新工作笔记本电脑具有我的原生(波兰语)语言环境集。但是,我根本无法使用除英语之外的任何语言的eclipse。我已经习惯了英文名字,我不懂翻译。

如何强制Eclipse以操作系统使用的其他语言开头?

2 个答案:

答案 0 :(得分:16)

好的,我明白了:

eclipse.ini应包含以下行:

-Duser.language=en_US

答案 1 :(得分:5)

如果在命令行中添加“-Duser.language = fr”或“-nl fr”(或者等效地将“osgi.nl = fr”添加到configuration / config.ini)没有明显的效果,那么你是缺少语言包(en_US是默认语言包)。

然后,您必须为相应的Eclipse版本添加“Babel语言包更新站点”。转到http://www.eclipse.org/babel/downloads.php进行查找。例如,Juno Babel语言包更新站点为http://download.eclipse.org/technology/babel/update-site/R0.10.0/juno。将此站点添加到您的可用软件站点(帮助:安装新软件:可用软件站点)。然后,您将能够选择相关的“用于Eclipse的Babel语言包”进行安装(例如,在这种情况下为fr)。自动重启后,您应该选择语言的用户界面。