iOS4 SDK和iPod touch第一代

时间:2010-07-22 14:39:57

标签: ios4 ipod-touch iphone-sdk-2.2.1

我有一个用iOS4 SDK编译的应用程序。 我想测试ipod touch 1st gen(OS2.2.1) 我已将部署目标设置为OS2.0和Base SDK为4.0.1

BUT

组织者告诉我:

“iPod”上的iPhone OS版本太旧,无法与此版本的iPhone SDK一起使用。请将设备恢复为下面列出的操作系统版本。

安装在iPod上的操作系统 2.2.1(5H11)

Xcode支持的iPhone OS版本 4.0.1 4 3.2.1(7B405) 3.2 3.1.3 3.1.2 3.1.1 3.1 3.0.1 3.0

从我的理解(纠正我,如果我错了),苹果现在需要使用ios4编译的应用程序,所以这些应用程序可以在ipodtouch第一代运行???

我错过了什么吗?

THX

1 个答案:

答案 0 :(得分:1)

正如它所说,你可以使用3.0以上的任何东西。 iPod touch 1G设备可以使用iOS 3和iOS 3.1,因此您应该在使用iOS SDK之前对设备进行升级。

免费获取贴纸的机会↓↓↓
豫ICP备18024241号-1