有没有办法将Visual Studio 2005的.NET框架版本更改为3.5?

时间:2009-05-20 12:12:10

标签: visual-studio-2005 frameworks

有没有办法将Visual Studio 2005的.NET框架版本更改为3.5?

3 个答案:

答案 0 :(得分:5)

没有。 Visual Studio 2005仅支持开箱即用的.NET 2.0。它可以更新为支持.NET 3.0

可以使用Visual Studio 2008 Express Edition编译.NET 3.5代码,或使用Mono编译Visual Studio 2008,我认为Windows/.NET SDK。但是,这些显然不会集成到Visual Studio 2005中。

答案 1 :(得分:1)

VS2008 / 2010有一种可视方式设置项目设置“TargetFrameworkVersion”,这使得它更容易,但是我发现向VS2005项目添加相同的标签将改变目标框架。您可以尝试将以下一(1)个添加到VS C#项目的部分中。

<TargetFrameworkVersion>v3.0</TargetFrameworkVersion>
<TargetFrameworkVersion>v3.5</TargetFrameworkVersion>
<TargetFrameworkVersion>v4.0</TargetFrameworkVersion>

答案 2 :(得分:0)

Visual Studio 2005仅支持.NET 2.0。在Visual Studio 2008中更改了解决方案文件(.sln)的格式,以允许您选择目标.NET版本。