运行npm-install时出错:无法安装。错误!没有提供版本

时间:2014-10-23 22:37:29

标签: node.js git mongodb npm

刚刚安装了新硬盘,安装了GIT,Mongodb,node和npm,将GIT添加到PATH,并尝试运行npm install -g。这是完整的错误消息:

npm ERR! addLocal Could not install .
npm ERR! Error: No version provided
npm ERR!     at needVersion (C:\Program Files\nodejs\node_modules\npm\lib\cache
add-local.js:144:40)
npm ERR!     at C:\Program Files\nodejs\node_modules\npm\lib\cache\add-local.js
77:10
npm ERR!     at C:\Program Files\nodejs\node_modules\npm\node_modules\read-pack
ge-json\read-json.js:51:40
npm ERR!     at final (C:\Program Files\nodejs\node_modules\npm\node_modules\re
d-package-json\read-json.js:349:17)
npm ERR!     at then (C:\Program Files\nodejs\node_modules\npm\node_modules\rea
-package-json\read-json.js:126:33)
npm ERR!     at C:\Program Files\nodejs\node_modules\npm\node_modules\read-pack
ge-json\read-json.js:316:48
npm ERR!     at evalmachine.<anonymous>:207:20
npm ERR!     at OpenReq.Req.done (C:\Program Files\nodejs\node_modules\npm\node
modules\graceful-fs\graceful-fs.js:141:5)
npm ERR!     at OpenReq.done (C:\Program Files\nodejs\node_modules\npm\node_mod
les\graceful-fs\graceful-fs.js:61:22)
npm ERR!     at Object.oncomplete (evalmachine.<anonymous>:107:15)
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Windows_NT 6.1.7601
npm ERR! command "C:\\Program Files\\nodejs\\\\node.exe" "C:\\Program Files\\no
ejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-g"
npm ERR! cwd C:\Users\username\NSFCyberHealth\server
npm ERR! node -v v0.10.32
npm ERR! npm -v 1.4.28
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     C:\Users\username\NSFCyberHealth\server\npm-debug.log
npm ERR! not ok code 0

我已经搜索过这个问题的其他人,但是我们找不到任何修复方法。这是我的package.json文件:

{
  "name": "node-authentication",
  "main": "server.js",
  "dependencies" : {
    "express" : "~3.4.4",
    "ejs" : "~0.8.5",
    "mongoose" : "~3.8.1",
    "passport" : "~0.1.17",
    "passport-local" : "~0.1.6",
    "passport-facebook" : "~1.0.2",
    "passport-twitter" : "~1.0.2",
    "passport-google-oauth" : "~0.1.5",
    "connect-flash" : "~0.1.1",
    "bcrypt-nodejs" : "latest",
    "socket.io" : "0.9.x",
    "JSV" : "4.0.x"
  }
}

有谁知道导致此错误的原因是什么?

3 个答案:

答案 0 :(得分:5)

是的,看起来它将-g视为包裹我不知道确切的原因但这些对我有用

  • 1:如果您以管理员身份打开cmd窗口,请将其关闭并打开 通常的cmd(不是管理员)
  • 2:在完成nodejs设置之前打开窗口,将其关闭 并重新打开它。

答案 1 :(得分:3)

如错误所示,您的package.json缺少version字段。添加一个,错误应该消失。

答案 2 :(得分:1)

您的package.json中需要一个版本,如下所示:https://www.npmjs.org/doc/files/package.json.html

  

package.json中最重要的事情是名称和   版本字段。这些实际上是必需的,而你的包装不会   安装没有他们。名称和版本一起形成标识符   这被认为是完全独特的。

相关问题