为iOS构建Flutter应用时出错

时间:2019-11-04 19:52:30

标签: ios flutter codemagic

尝试构建Flutter应用时,codemagic在下面显示错误。

== Building for iOS ==
Failed to build iOS app
Error output from Xcode build:
↳
    ** BUILD FAILED **


Xcode's output:
↳
    /Users/builder/programs/flutter/.pub-cache/hosted/pub.dartlang.org/device_id-0.2.0/ios/Classes/DeviceIdPlugin.m:2:9: fatal error: 'device_id/device_id-Swift.h' file not found
    #import <device_id/device_id-Swift.h>
            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    /Users/builder/programs/flutter/.pub-cache/hosted/pub.dartlang.org/device_id-0.2.0/ios/Classes/DeviceIdPlugin.m:2:9: note: did not find header 'device_id-Swift.h' in framework 'device_id' (loaded from '/Users/builder/clone/build/ios/Release-iphoneos/device_id')
    1 error generated.
    note: Using new build systemnote: Planning buildnote: Constructing build description

Encountered error while building for the device.


Build failed :|
Failed to build for iOS

0 个答案:

没有答案
豫ICP备18024241号-1